Mountain Project Logo

Offline photos... still broken.


Original Post
Josh Janes · · Unknown Hometown · Joined Jun 2001 · Points: 9,015

Last week I took a chance with the app after swearing it off for the better part of 6 months and downloaded all photos for Unaweep Canyon in anticipation of making a trip there and not having reception.

After the supposedly successful download, I put my phone in airplane mode to test things out and all the photos did indeed appear to be available.

I turned off airplane mode and drove to Unaweep and, as expected, gradually lost all reception... except that once I got there, none of the photos were available. Black placeholders, spinning wheels, error messages... What a drag. All the photographic beta and topos I was relying on were unavailable. I'm surprised this issue hasn't been addressed as it is a major one.

Ironically, I was so worried about it that I tried to save the photos to my phone so I could view them independently of the app just in case - but the app doesn't even allow you to save photos via a standard tap-and-hold gesture. The only way to do this is to take screen shots.

Curious if this problem is being addressed?

carla splitter · · San Jose, CA · Joined Mar 2016 · Points: 111

I also am frustrated that downloaded photos are not saved when you put the app in airplane mode or there is no service.. 

F loyd · · Kennewick, WA · Joined Mar 2018 · Points: 406

Wow, didn't know that happened. You saved me the frustration. 

NCD · · Boulder, CO · Joined Jan 2015 · Points: 50

This happens to me also fairly often. The 1rst photo in a gallery for a route or area will display but then all the others will not show up. The caption will still be there for each missing photo but no image ever loads.

Nick Wilder · · Boulder, CO · Joined Jan 2005 · Points: 3,879

We haven't had an app developer for several months and are interviewing now.  This is on the list when we have someone back on them!

Adam Pecan · · Moab, UT · Joined Apr 2012 · Points: 160

Yep been sandbagged by this many times after doing a big hike in. The app is fairly worthless without this feature.   Any timeline on a fix?

Marc801 C · · Sandy, Utah · Joined Feb 2014 · Points: 65
Adam Pecan wrote: Yep been sandbagged by this many times after doing a big hike in. The app is <s>fairly</s> totally worthless without this feature.   Any timeline on a fix?

Fixed that for ya!

J M · · Oakland, CA · Joined Sep 2015 · Points: 145

@Nick - can you post the APK for the older app version until this offline photo bug is fixed? Seems like a good workaround until you bring another developer on board.

I had to deal with this issue last week. It's very frustrating to think​ you have photos downloaded for offline use ... and find out the hard way when completely out of cell service for several days.

grog m · · Saltlakecity · Joined Aug 2012 · Points: 70

My current technique is to take screenshots of beta photos from MP. That way I can quickly and reliably access them. 

Seb303 · · Denver, CO · Joined Sep 2015 · Points: 10

I miss the old MP app and the old site format.  Wish I'd never downloaded the update. Also miss the graps that used to show up on ones page showing how many pitches of various grades they'd climbed and whether they were sport, trad or mixed.  MP took the "if it's not broken, let's break it" approach rather than if it's not broke don't fix it.

Goofy JungleMan · · Unknown Hometown · Joined Apr 2018 · Points: 32

What is the status of this fix? This happened to me again last weekend at Trout Creek, Oregon. 

JSH · · Unknown Hometown · Joined Apr 2007 · Points: 1,028

It may depend on OS?  I upgraded phones this summer to a Pixel 2, which stays updated with the most recent Android, and the photos showed up for me in an offline area last weekend.

EDIT -->> I was wrong;  put the device in airplane mode, all pictures gone, even for individual routes.

Eric Internicola · · Westminster, CO · Joined May 2011 · Points: 25
Update1: It turns out that I did not reproduce this issue, it's just that the subareas of "Animal Wall" do not have any area photos.    

I will be digging into this more to see if I can reproduce it.  Can you give any more detail that will help me reproduce this issue?

Update2: I've tested in both iOS and Android and have been unable to reproduce this issue on either platform.

In order to catch this, we will have to add some more checks in code to try to trap this and report it when it happens.  Again, thanks for being patient on this issue, it's a lot more difficult to solve when you can't reproduce it.

Hey all, I know this has been a big pain point.  I'm happy to say that I've been able to reproduce this error (which means it can be fixed, definitively).  Here are the steps I followed to reproduce it (using the "Animal World" area as my test area):
  1. Clean Install Mountain Project on iPhone
  2. Install a data pack (Colorado)
  3. Download all images for the area (Animal World)
  4. Put device in airplane mode
  5. Open app and see that images are not visible.
The images are not visible for the area, however they ARE available for the individual routes.  We'll get this fixed and released as soon as we can.  Thanks for being patient! 
Alex S · · Ridgecrest CA · Joined Sep 2013 · Points: 490

I too have had this issue for the better part a year now.

The soloution for me on my Samsung galaxy 6 is after downloading all photos from an area i need to manually view all of the thumbnails on the scrollbar of each route/area  if the thumbnails are loaded the full images will be displayed once offline.

And while your fixing photos, could there be a manual override option to download all photos for an entier region regarless of size.  When im going on a road trip to somewhere new, i would like to have the option to download all 6000 images while i am at home on my personal wifi, rather then haveing to open each sub area and downlaod a few hunderered images at a time.

skelldify · · Unknown Hometown · Joined Jul 2014 · Points: 135

Any udpates on this? Got screwed by it last weekend, ended up doing lots of wandering around... Not a big fan of the latest update, in general.

Jason Anderson · · Boulder · Joined Jul 2005 · Points: 105

Regarding offline photos missing or disappearing, Eric and I spent a lot of time last month trying to reproduce this and identify potential causes in the code.  Please try version 4.2.0 for android that we released on Tuesday and the ios update coming on Monday.  For the best chance of success, remove and reinstall the app, or delete and reinstall the state area.  If that's not appealing, you must at least tap Download All Photos again on the crags you want.  If the problem is still happening, let us know some details, like when you downloaded the state area, when you downloaded photos for the crag, whether you browsed the crag and photos before or after downloading, if the photos work on the crag but not the routes, or if your phone is low on storage space.

JSH · · Unknown Hometown · Joined Apr 2007 · Points: 1,028

I uninstalled, reinstalled, downloaded all in one area, turned on airplane mode, and it's worked so far.

Thanks much for spending time on this. It's greatly appreciated.

Guideline #1: Don't be a jerk.

iPhone & Android App Feedback
Post a Reply to "Offline photos... still broken."

Log In to Reply