Edelrid Harness Rubber Tie-in Point


Original Post
Zachary McLaughlin · · New Haven, Connecticut · Joined Jul 2013 · Points: 0

Does anyone have issues with the rubber gasket on the tie-in point breaking? I have had this happen twice to me.

Tim Neumann · · Unknown Hometown · Joined Feb 2017 · Points: 40
Pic

If you mean this bit, than yes. It went after a year or so on my Orion harness. I checked if there's any sign of increased wearing out in that particular spot from time to time but there's really no difference noticeable (I've been climbing frequently without the plastic thingy for about 1.5 years). Don't worry and just keep an eye on it every now and again.
John Wilder · · Las Vegas, NV · Joined Feb 2004 · Points: 1,530

Nope- i've had three Edelrid harnesses and retired two due to wear on other parts of the harness.

Khoi · · Vancouver, BC · Joined Oct 2009 · Points: 45

I've had 2 Edelrid harnesses (Jay and Logan) that had them - no problems whatsoever.

One of my local gyms bought a bunch of Edelrid Jays for their rental fleet, and a few of them eventually had issues with that part.

So maybe there was a bad batch???

Tim Neumann · · Unknown Hometown · Joined Feb 2017 · Points: 40
Tim Neumann wrote:  If you mean this bit, than yes. It went after a year or so on my Orion harness. I checked if there's any sign of increased wearing out in that particular spot from time to time but there's really no difference noticeable (I've been climbing frequently without the plastic thingy for about 1.5 years). Don't worry and just keep an eye on it every now and again.

Nevermind...


Guideline #1: Don't be a jerk.

Post a Reply

Log In to Reply